Results 1 to 10 of 10
  1. #1
    JK Super Freak atomicmecha's Avatar
    Join Date
    May 2007
    Location
    Gaithersburg, MD
    Posts
    1,761

    Exclamation check engine light with no codes? WTF?

    ok, so what's going on is that my jeep has the little engine light turned on right now, and after a few seconds of being turned on, i get the annoying little "DING".

    I did the code check (turned the system on and off several times till the OD went to all dashes) and it just display's "DONE" and goes away. so there are no error codes in the system.

    the jeep seems to run fine, and drives the same, considering (i'll explain later). the only thing out of the odinary is that its getting 12-13mpg in the city instead of its normal 14-15.



    now, i don't want to go running off to the dealer because of what happened last time it did this. yes, its done this before. the light came on one evening when i was leaving work, so i stopped at the dealer since it was on the way home.

    they said the computer was reporting an "EVAP leak" and the checked the whole system with a dye and found no leaks, and cleared the code, drove it and let it run for a few minutes and the code never came back. they said it might have just been bad gas or something. so i paid them $100 to tell me nothing was wrong and to turn the light out.

    I REALLY DON'T WANT TO DO THAT AGAIN. F#&K'n DEALER!


    so, what could be the problem? and how can i make the dealer do something other then turning the light out and charging me. does it help that the first time it happend was only 3 weeks ago?

    can i just pull the plug on the jeep (aka remove battery) and let it sit for an hour or so to clear it's memory and go from there?

    i don't use the radio, so i couldn't give one rat's ass about loosing the presets the mechanics at the dealer set on my radio.


    any ideas? help? tips? ways to f#&k the dealer instead of me getting f#&k'd again?











    and when i meant it drives fine considering, i meant that there are some other things going on with it that were not present when i brought it. but i believe its just wear and tear on the tires.

    for example, when ever i take a hard turn to the left, there's a vibration and almost grinding sound coming up the steering wheel. no noise, just a vibration in the steering wheel. stuff like that...
    1992 S-10 Blazer 4dr Jet Black riding on 31x10x15 Mud Terrain's
    current plan:
    - 5" suspension lift
    - 3" body lift
    - 33x14.5 tires
    - LSD in front
    - Electric locker in rear
    - and much more

    Had: 07 JK Unlimited Rubicon - Steel Blue w/ TFBB 2.5" lift
    www.core4x4.org - 4wd club I belong to.
    NC Beach Buggy Member #13582

  2. #2
    JK Enthusiast micja's Avatar
    Join Date
    Oct 2008
    Location
    Cheyenne, WY
    Posts
    151

    Default

    cant speak much on JK problems since mine has been golden, but my vw jetta turbo has been throwing emissions codes left and right lately. After having it checked over and over from front to back by my very trusted local mechanic, he told me that here locally that the fuel being delivered to the gas stations has not been mixed correctly and drastically increasing the number of emissions related check engine lights. Untill all of the fuel is used up from all of the stations, people will continue to have problems. Don't know if this is your issue but the only other thing I would think would be an 02 sensor. If you know someone that has a scan tool with a live data feature you will be able to drive with it and see whats going on. That is how i could confirm that there was nothing wrong with my car. Its a little too expensive to have the fuel tested and i don't know if it would do any good anyways. Just reset my light and kept driving on.
    08 Wrangler X 2Dr - Steel Blue, 6 Speed
    Factory E-disco (Flipped) & Rear Locker 3.73 Gears
    33 x 12.5 Mickey Thompson MTZ's
    15 x 10 Procomp 8179
    Ruged Ridge Modular Front Bumper
    Warn M8000 winch
    Treks Offroad Rear Bumper W/Tire Carrier
    Treks Front Long Arms
    OME Long Travel HD lift
    Flowmaster 40 Series Muffler<-- hear it roar!
    Cut Fenders
    OR-FAB Cage
    Bed Lined Interior On Hard Top
    Adjustable and serviceable ball joints
    The list gets longer and longer...
    www.northridge4x4.com

  3. #3
    JK Super Freak JK-Tex's Avatar
    Join Date
    Mar 2009
    Location
    Austin, TX
    Posts
    1,527

    Default

    Yah, what's with all the bad gas (no pun intended) lately? I got a tank at my local Shell station. Lots of hesitation and some weird smells when I turned it off and parked. No CEL, thankfully.

  4. #4
    JK Super Freak atomicmecha's Avatar
    Join Date
    May 2007
    Location
    Gaithersburg, MD
    Posts
    1,761

    Default

    Quote Originally Posted by JK-Tex View Post
    Yah, what's with all the bad gas (no pun intended) lately? I got a tank at my local Shell station. Lots of hesitation and some weird smells when I turned it off and parked. No CEL, thankfully.

    oddly that last time this happend, i had recently filled up with shell... and right before it happened this time, i filled up with shell.


    hmmm...........
    1992 S-10 Blazer 4dr Jet Black riding on 31x10x15 Mud Terrain's
    current plan:
    - 5" suspension lift
    - 3" body lift
    - 33x14.5 tires
    - LSD in front
    - Electric locker in rear
    - and much more

    Had: 07 JK Unlimited Rubicon - Steel Blue w/ TFBB 2.5" lift
    www.core4x4.org - 4wd club I belong to.
    NC Beach Buggy Member #13582

  5. #5
    JK Enthusiast Chainsawjames's Avatar
    Join Date
    Dec 2008
    Location
    MA
    Posts
    192

    Default

    I have an 07 Rubicon with 26000 miles. The engine light comes on intermittently. I check it with a scanner and nothing. While im not a mechanic or an engineer, I bet it has something to do with the different fuel additives and or blends. Ive talked to a few mechanics and they second that. I also understand that every state has different laws regarding the additives used in fuel.

  6. #6
    JK Freak 4WHLN's Avatar
    Join Date
    May 2008
    Location
    In a JEEP down by the river, br louisiana
    Posts
    945

    Default

    mine did this and it was the PCM. the dealer had to change it.

    WAVE BACK DAMMIT
    [___]
    (O lllllll O)
    [ ]----o--[ ]

    BLACK 2 DR X
    EAT, JEEP, SLEEP
    All my upgrades come from WWW.NORTHRIDGE4X4.COM

  7. #7
    JK Super Freak atomicmecha's Avatar
    Join Date
    May 2007
    Location
    Gaithersburg, MD
    Posts
    1,761

    Default

    Quote Originally Posted by Chainsawjames View Post
    I have an 07 Rubicon with 26000 miles. The engine light comes on intermittently. I check it with a scanner and nothing. While im not a mechanic or an engineer, I bet it has something to do with the different fuel additives and or blends. Ive talked to a few mechanics and they second that. I also understand that every state has different laws regarding the additives used in fuel.

    think i should reset the computer after my next fill up and see if it stays out? granted that i use some other brand of fuel.


    Quote Originally Posted by 4WHLN View Post
    mine did this and it was the PCM. the dealer had to change it.

    two questions... 1, how'd you convince them to do that? and 2, would a ton of mud cause the PCM to go bad? i've gotten mud in just about every noke and crack of my jeep.
    1992 S-10 Blazer 4dr Jet Black riding on 31x10x15 Mud Terrain's
    current plan:
    - 5" suspension lift
    - 3" body lift
    - 33x14.5 tires
    - LSD in front
    - Electric locker in rear
    - and much more

    Had: 07 JK Unlimited Rubicon - Steel Blue w/ TFBB 2.5" lift
    www.core4x4.org - 4wd club I belong to.
    NC Beach Buggy Member #13582

  8. #8
    JK Freak 4WHLN's Avatar
    Join Date
    May 2008
    Location
    In a JEEP down by the river, br louisiana
    Posts
    945

    Default

    two questions... 1, how'd you convince them to do that? and 2, would a ton of mud cause the PCM to go bad? i've gotten mud in just about every noke and crack of my jeep. [/QUOTE]

    My Jeep had 700 miles on it when it did this. Brought it to the dealer 3 times before they finally replaced the PCM. The first time I brought it they did a flash. Brought it back the next day (check engine light came on as I pulled into my garage) and they flashed it again. But this time there was a new "update" from Chrysler. This time the light came on while the Service Mgr and I were signing the service ticket. Brought it back a couple days later and they installed the new part.
    No problems since.

    As for the mud, Im sure they will look at that and say that the mud caused it. I dont think it would, but like I said I only had 700 miles on mine and it hadn't been off road at that point.

    WAVE BACK DAMMIT
    [___]
    (O lllllll O)
    [ ]----o--[ ]

    BLACK 2 DR X
    EAT, JEEP, SLEEP
    All my upgrades come from WWW.NORTHRIDGE4X4.COM

  9. #9
    JK Junkie blockrockin's Avatar
    Join Date
    Jan 2008
    Location
    maryland
    Posts
    2,128

    Default

    mine also has been showing a check engine light .. but not showing any codes ?

  10. #10
    JK Freak moabjk072d's Avatar
    Join Date
    Aug 2008
    Location
    Pleasant Grove, UT
    Posts
    522

    Default

    Quote Originally Posted by blockrockin View Post
    mine also has been showing a check engine light .. but not showing any codes ?
    Some codes will not show with the key on off trick, you have to have a scanner to see them.
    I found this out after I had a engine light come on and no code would show, I hooked up my hypertech scanner and there they were. I cleared the code and fixed my problem and no more codes.

    (the problem was a leak on my evap from when I did the relocation)
    2009 Deep water blue 2door/ 2013 True Blue Rubi 4 Door
    Factory 10 Chromoly shafts w/ Cold Forged U-joints & full circle clips.
    TF disco's,TF Rocker Guards,TF Rear bumper, TF Sleeves & gussets
    Airaid Cold air intake
    Hypertech programmer
    5:13's
    37" SS M-16's
    Incubus off road 17's
    4"Teraflex and 1.5" Spacers
    1"body lift
    Front Rubi E-locker and Rear Eaton E-locker
    All X up front bumper
    Magnaflow Catback Exhaust
    Bushwacker Flat fender flares
    XRC-8 w/10,000lb synthetic rope

  11. Default JK-Forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •