MyGig 430N RHB - Page 3

Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: MyGig 430N RHB

  1. #21
    JK Newbie
    Join Date
    Apr 2011
    Location
    Arlington, Virginia
    Posts
    22

    Default 430N issues

    Purchased brand new 2011 JK with 430N and Uconnect group. Ipod doesnt work and Uconnect doesnt work. Good thing I kept the dealer specs sticker b/c I will go back in a week or so and have them fix it. On another positive note, got mud on the 430n screen and buttons and it still works fine. I better clean it before I bring it in huh. Hopefully this April upgrade will fix it.

  2. #22
    JK Enthusiast evan631's Avatar
    Join Date
    Dec 2010
    Location
    Oakdale, New York (Long Island)
    Posts
    228

    Default

    Quote Originally Posted by Desert.Rat View Post
    Purchased brand new 2011 JK with 430N and Uconnect group. Ipod doesnt work and Uconnect doesnt work. Good thing I kept the dealer specs sticker b/c I will go back in a week or so and have them fix it. On another positive note, got mud on the 430n screen and buttons and it still works fine. I better clean it before I bring it in huh. Hopefully this April upgrade will fix it.
    Uconnect should work for the phone.

    As for the ipod, and bluetooth streaming...we will need an update for the 430. It is not available as of two weeks ago when i was at the dealer.

    Once it is avail, you should be able to download it yourself and do the update via CD. Just read instructions carefully.

    -Evan
    -Evan

  3. #23
    JK Newbie GeorgesJeep's Avatar
    Join Date
    Dec 2010
    Location
    VA/ DC Metro
    Posts
    56

    Default

    Not to bring back a thread from the dead but I'd like to share my recent findings on this annoying issue.

    Just to let you guys know. I have a 2011 equipped with the 430N RHB. I have a jailbroken 3GS iPhone which was previously running off 3.1.3 firmware. I was having no issues with bluetooth or direct connectivity. It worked perfect.

    Last week I decided to upgrade my iPhone firmware to the latest version of 4.3.3. I did this without researching any issues others may have been having with the 4.3.3 firmware. I restored my iPhone to manufacture settings and updated the firmware, I then jailbroke it. I was happy to have the latest firmware on the phone, however that was short lived. Turns out the 430N RHB software is not compatible with the 4.X iPhone firmware, only 3.X. Okay well that's bad. It gets even better, Apple's latest firmware release turns out to kill the 3GS of its battery life and service reception. The 4.X firmware was designed to run off a iPhone 4 not 3GS. Apple is working on repairing the issue, so they say. I just downgraded back to the 3.1.3 firmware and the iPhone once again works perfect with the 430N RHB.

    So, if you have a 430N RHB, note that your unit will only work with a iPhone using 3.X firmware until the 430N RHB software is updated or Apple fixes the issue on their end. I'm not holding my breath for either of them.

    I’ll most likely end up purchasing the MyGig LockPick CHR-550 due to all the cool features it offers, Netflix streaming from iPhone to MyGig, DVD viewing while in drive just to name a few.

  4. #24
    JK Newbie Firewire's Avatar
    Join Date
    Apr 2007
    Location
    Midwest City, OK
    Posts
    86

    Default

    For the OP,

    I just did the update this evening and it is very simple. Just be sure and copy ONLY the files IN the RHB update folder on the cd, not the folder itself. The extra files are just instructions (scans) of the original instructions.

    Here is a link from the Mygig forum on where and how to do it: RHB 430N Update

    The RAR file from the link on the Mygig forum is here: http://www.mediafire.com/?fx6hx7eae1zys5p
    Last edited by Firewire; 07-03-2011 at 10:24 PM.
    '11 Rubicon Unlimited
    /l ,[____],
    l---L -OlllllllO-
    ()_) ()_)--o-)_)

  5. #25
    JK Newbie Firewire's Avatar
    Join Date
    Apr 2007
    Location
    Midwest City, OK
    Posts
    86

    Default

    Well....now the Iphone 4 ver. 4.3.3 won't connect, but 1 out 6-10 times. Keeps saying "Reading" then after a minute or so "Error Occurred".

    I did some research on google which took me to a Challenger forum and the fix was a technical bulletin for the dealership to update the Uconnect device.

    Service Bulletin 08-036-11 June 29, 2011

    My wife is not happy with me now! I upgraded mine last night and never checked the iphone compatibility and then upgraded hers this morning. She called me quickly after leaving telling me it no longer worked. Her iphone is on ver. 4.2 by the way.

    I wish I could go back to the old version now.
    '11 Rubicon Unlimited
    /l ,[____],
    l---L -OlllllllO-
    ()_) ()_)--o-)_)

  6. Default JK-Forum


Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •