Notices
JK Off-Road 101 Bulletin board forum regarding topics such as general off-roading tips, tricks, techniques and equipment usage such as winching and vehicle recovery information.
Sponsored by CARiD
Click Here

Signs of Hydrolock?

 
Old 05-29-2010, 01:32 AM
  #21  
JK Newbie
 
Join Date: May 2009
Location: SE Pennsylvania
Posts: 65
Likes: 0
Received 0 Likes on 0 Posts
Default

Still running stock battery, if so that's it. I have heard several cases of the stock battery giving up and still testing fine. These new jeeps have some strange electrical issues.
JeepersHeart is offline  
Old 05-31-2010, 09:13 AM
  #22  
JK Freak
 
JMP8562's Avatar
 
Join Date: Jun 2007
Location: MOKENA ILL
Posts: 813
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by toad View Post
If it decides not to start again, put it in neutral and see if it will turn over.
try that ,, sometimes i get in and CLICK CLICK bump the shifter and it starts i have an automatic
JMP8562 is offline  
Old 07-12-2010, 06:45 PM
  #23  
JK Enthusiast
 
Join Date: Jul 2008
Location: cincinnati oh
Posts: 318
Likes: 0
Received 0 Likes on 0 Posts
Default

heres a good sign of hydrolock. its out of a 2010 with 4000 miles. i had a bad weekend...

[IMG][/IMG]
kking08 is offline  
Old 10-02-2010, 09:38 AM
  #24  
JK Enthusiast
 
sahara-07's Avatar
 
Join Date: Dec 2009
Location: outaouais
Posts: 167
Likes: 0
Received 0 Likes on 0 Posts
Default

ouff that is bent !!
sahara-07 is offline  
Old 10-02-2010, 08:02 PM
  #25  
JK Freak
 
zero_traction69's Avatar
 
Join Date: Aug 2009
Location: los vegas
Posts: 857
Likes: 0
Received 0 Likes on 0 Posts
Default

not being able to start jeep hahaha
zero_traction69 is offline  
Old 11-14-2010, 07:22 PM
  #26  
JK Enthusiast
 
Join Date: May 2008
Location: Russellville, arkansas
Posts: 156
Likes: 0
Received 0 Likes on 0 Posts
Default

I know it tested good but I would borrow a battery from someone and see how it works and check all the wires for loose connections. good luck
mcgeeusmc20 is offline  
Old 11-15-2010, 05:27 PM
  #27  
JK Freak
 
08JKRHD's Avatar
 
Join Date: Sep 2010
Location: Big Swamp, NC
Posts: 519
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by JeepersHeart View Post
Still running stock battery, if so that's it. I have heard several cases of the stock battery giving up and still testing fine. These new jeeps have some strange electrical issues.
yeah,I just had my stock battery go...it tested fine and it would jump off easy, but charging never kept it going for more than a day. Bought a yellow top cranked everytime since I got it in there.
08JKRHD is offline  
Old 11-17-2010, 02:28 PM
  #28  
JK Freak
 
Join Date: Sep 2006
Location: SFV-LA, CA
Posts: 855
Likes: 0
Received 0 Likes on 0 Posts
Default

Do yourself a favor and dump that piece of shit stock battery. Get an optima or similar quality battery, clean your connections and check your wires. That'll do it.
Augie is offline  
Old 11-17-2010, 04:33 PM
  #29  
JK Freak
 
Tgoods 09 X's Avatar
 
Join Date: Oct 2009
Location: Lake Villa, IL
Posts: 787
Likes: 0
Received 0 Likes on 0 Posts
Default

Here are a couple other signs of Hydrolock...
Attached Thumbnails Click image for larger version

Name:	Intake.jpg
Views:	159
Size:	75.2 KB
ID:	102950   Click image for larger version

Name:	Block.jpg
Views:	179
Size:	62.3 KB
ID:	102951   Click image for larger version

Name:	Bell Housing.jpg
Views:	152
Size:	47.3 KB
ID:	102952   Click image for larger version

Name:	Oil Pan.jpg
Views:	168
Size:	71.9 KB
ID:	102953  
Tgoods 09 X is offline  
Old 11-20-2010, 03:21 PM
  #30  
JK Newbie
 
BlueSubmarine's Avatar
 
Join Date: Nov 2010
Location: San Francisco, CA
Posts: 82
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by Tgoods 09 X View Post
Here are a couple other signs of Hydrolock...
Holy crap, that sucks.

On another note, I had this problem a while back too. Go to start the jeep, hear the normal sounds and then nothing, even cabin electricals disappeared. When I opened up the hood to check it out I just had simply touched the battery cables and I heard all my electricals come back on. Happened to me maybe 10 times before it went away, weird. Touching the cables worked every time. Next time, try touching your negative cable, see if that works.
BlueSubmarine is offline  

Quick Reply: Signs of Hydrolock?


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: