Clicking noise problem under the jk - JK-Forum.com - The top destination for Jeep JK Wrangler news, rumors, and discussion

Notices
JK Talk General discussion forum regarding thoughts, opinions and rumors about the Jeep JK Wrangler or related subjects that don't quite fit in the Modified, Stock or Electronics forums.

Clicking noise problem under the jk

 
Old 03-15-2019, 08:30 PM
  #1  
JK Newbie
Thread Starter
 
Join Date: Mar 2019
Location: Ridgewood, New York
Posts: 4
Thanked 0 Times in 0 Posts
Exclamation Clicking noise problem under the jk

Hi friends

I'm having a problem with my 2013 JK, I recently upgrade the tires to ( Cooper Stt Pro 325X65 18R "MONSTER TIRES" ), 4.88 gear, 2 1/2" boost lift for now and front control ams, after 100 miles I started hearing a clicking noise "sounds like 2 metals are clicking under the car" every time I accelerate or decelerate is only ONE click noise is not continuous sound, I thought it was from the transmission, gear or muffler but my mechanic said not.

hope anyone can help me thank you so much!


AlexWladimir is offline  
Old 03-16-2019, 02:03 AM
  #2  
JK Jedi
 
resharp001's Avatar
 
Join Date: Jun 2013
Location: Willow Park, TX
Posts: 4,055
Thanked 193 Times in 188 Posts
Default

After modifying a suspension, you should always recheck torque on everything you touched after 500 miles or so. The timing of your noise is interesting considering you just installed all that stuff about a month ago. I would start by checking torque on all components that you touched. If you are getting a single sound when alternating between acceleration and deceleration, a lot of times that points to a control arm bolt. Think of the weight of the jeep shifting back and forth.....you get a single movement "click" and then things stay in that position until the weight of the jeep shifts the opposite direction (forward or backward) again. The times I've had this be a CA bolt though, the noise was only coming to a stop and then accelerating from a stop....rather than every time stepped on or let off the peddle. Still, that is where I would start if it were my jeep. Reconfirm torque on everything.
resharp001 is offline  
The Following User Says Thank You to resharp001 For This Useful Post:
AlexWladimir (03-17-2019)
Old 03-16-2019, 03:00 PM
  #3  
JK Enthusiast
 
cedarraider's Avatar
 
Join Date: Jun 2014
Location: Traverse city MI
Posts: 394
Thanks: 0
Thanked 4 Times in 4 Posts
Default

Check your ball joints too. Mine was mire of a clunk than a click but good story to check.
cedarraider is offline  
The Following User Says Thank You to cedarraider For This Useful Post:
AlexWladimir (03-17-2019)
Old 03-17-2019, 04:20 PM
  #4  
JK Newbie
Thread Starter
 
Join Date: Mar 2019
Location: Ridgewood, New York
Posts: 4
Thanked 0 Times in 0 Posts
Default

thank you so much for your info, you were right, i double check all the updates i made to the jeep and i hove no sound anymore... thank you!!
AlexWladimir is offline  
Old 03-17-2019, 04:20 PM
  #5  
JK Newbie
Thread Starter
 
Join Date: Mar 2019
Location: Ridgewood, New York
Posts: 4
Thanked 0 Times in 0 Posts
Default

Thanks to you too my friend i checked that too !!

thanks
AlexWladimir is offline  
Old 03-17-2019, 06:30 PM
  #6  
JK Jedi
 
resharp001's Avatar
 
Join Date: Jun 2013
Location: Willow Park, TX
Posts: 4,055
Thanked 193 Times in 188 Posts
Default

Did you find a specific bolt that took a bit more torque?
resharp001 is offline  
 


Quick Reply: Clicking noise problem under the jk


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: