JK Rubicon E-Swaybar Disconnect Mod - Page 6 - JK-Forum.com - The top destination for Jeep JK Wrangler news, rumors, and discussion

Notices

JK Rubicon E-Swaybar Disconnect Mod

Reply

 
 
Old 12-15-2017, 09:53 PM
  #51
JK Newbie
 
eastforku's Avatar
 
Join Date: Dec 2017
Location: Pocatello, Idaho
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default No pics

Sorry for the newbie question, but I don't see any of the pics. Is there a setting I need to change?
eastforku is offline  
Reply With Quote
Old 12-15-2017, 09:59 PM
  #52
JK Newbie
 
eastforku's Avatar
 
Join Date: Dec 2017
Location: Pocatello, Idaho
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default Loose Sway Bar

Hello. The reason I am so interested in the pics is because of what happened with my 2014 JKU. Was installing a lift today and noticed the passenger side of the sway bar had almost completely pulled out of the electronic disconnect housing. So I was driving around with my sway bar permanently disconnected. Got it pushed back in, but I still need to pull it apart to find out what broke to allow that bar to move. Anybody heard of this?
eastforku is offline  
Reply With Quote
Old 01-12-2018, 03:22 AM
  #53
JK Enthusiast
 
baileyj's Avatar
 
Join Date: Oct 2011
Location: Phenix City, AL
Posts: 119
Thanks: 0
Thanked 0 Times in 0 Posts
Default

If you haven't already seen this, check out this study, very informative.
https://www.jk-forum.com/forums/stoc...-study-153545/
baileyj is offline  
Reply With Quote
Old 01-18-2018, 09:04 AM
  #54
JK Newbie
 
Join Date: Apr 2017
Location: Richmond,va
Posts: 15
Thanked 0 Times in 0 Posts
Default

MY big question is... What are you all doing that causes this. I disconnect my sway bar when I air down and lock into 4Lo. Is anyone doing anything different? Its nice having the system. From what I have read it sounds like they just go without warning. Makes me think about removing it when it goes completely.
Cjcain is offline  
Reply With Quote
Old 01-20-2018, 04:51 AM
  #55
JK Enthusiast
 
baileyj's Avatar
 
Join Date: Oct 2011
Location: Phenix City, AL
Posts: 119
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I did nothing, one day, it stopped working. They over-complicated a process that is simple, all in the name of safety, especially for those who are not experienced wheelers. The system has its own computer board the size of a desktop motherboard, that's what failed. The motor for this system is strong, I even wired it so I could control it from inside, then the engagement spring on the end of the motor failed. I then said to hell with it and got the EVO manual disconnect the mounts directly where the motor was located, works great. I go wheeling, turn knob to disengage, when done, turn knob to re-engage.
baileyj is offline  
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
doojer
JK Write-Ups
52
05-27-2015 08:04 PM
brokenleaf
JK Suspension
2
03-13-2009 07:54 AM
Bluewaterrider
Stock JK Tech
4
02-02-2008 06:17 PM
brknmach
Modified JK Tech
2
11-13-2007 07:42 PM
RedRockJK
Modified JK Tech
0
06-26-2007 07:37 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 01:57 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: