Superchips 'Easy Update' NOT easy! Not helpful - Page 2 - JK-Forum.com - The top destination for Jeep JK Wrangler news, rumors, and discussion

Notices

Superchips 'Easy Update' NOT easy! Not helpful

Reply

 
 
Old 04-02-2011, 09:04 AM
  #11
JK Freak
 
XBlacky08X's Avatar
 
Join Date: Oct 2010
Location: Holyoke, MA
Posts: 536
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by utahcrawler
I have been a fan of Superchips since I did the tune on my JK, this is changing, I needed some warranty work done and reset my JK to stock, the dealer changed some of the settings, now I need an update.

Easy update is not easy. Called Superchips, they blamed my computer and firewall, installed the update on a computer with High Speed internet, no firewall, still the computer won't register the device...I have tried everything they suggest... Absolutely not helpful on the phone...basically it is completely useless at this point.

Any suggestions out there, besides go to a different programmer?
I had a similar experience with superchips a few months ago. I bought the flashpaq, updated it, and it still would not work on my jeep. Long story short, it took several emails and phone calls and me making some noise on these forums for them to finally react and correct the problem. Everything is awesome now so I guess it was worth the wait... However, their servers suck and their techs seem like standard blue-collar workers that could care less about your situation. On the other hand, many people have had great results right off the bat.. For me it was sub-par to say the least.. Good luck

Last edited by XBlacky08X; 04-02-2011 at 09:06 AM.
XBlacky08X is offline  
Reply With Quote
Old 04-02-2011, 09:39 AM
  #12
cfr
JK Freak
 
cfr's Avatar
 
Join Date: Jan 2009
Location: Longmont, CO
Posts: 623
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Mine is updating now.

I started their app, then plugged in the flashpaq. No devices.

Stopped the app. Unplugged the flashpaq. Plugged in the flashpaq again. Started the app. Then it found the flashpaq.

Worked for me.
cfr is offline  
Reply With Quote
Old 04-02-2011, 11:14 AM
  #13
JK Enthusiast
 
Join Date: Nov 2010
Location: Fort Collins, Colorado
Posts: 174
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I was having similar issues. New Sony laptop, Windows 7, T-1 line, nothing worked. Tethered the laptop to my Iphone(on Edge even), worked great. Seemed like a slower connection was my fix. Is it possible Superchips servers can't keep up?
jimk403 is offline  
Reply With Quote
Old 04-02-2011, 04:12 PM
  #14
JK Enthusiast
Thread Starter
 
utahcrawler's Avatar
 
Join Date: Sep 2010
Location: Highland, Utah
Posts: 148
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by GutlessPhred View Post
Can you update with a mac? That's all I have and I use the Mac os.
Superchips doesn't work with Mac, you must have a PC (unless maybe if you are running windows on your mac)...thanks for the input, still no luck, I have so many cables around the house I don't know which one was the original from Superchips, I am using one that matches the end and it does power up the superchips module with the same options I see when I want to program the JK. I talked again and superchips said I could mail it to them to have them update it, I am hesitant to do so...with their service as it has been...I am worried I will never see it again, but at this point it is useless anyway, I might just need to take the chance and mail it in. I have tried two different PC's at two different locations, two different internet connections, plugging/unplugging in different ways..the 'easy update' still won't recognize the module. Unreal.

Last edited by utahcrawler; 04-02-2011 at 04:19 PM.
utahcrawler is offline  
Reply With Quote
Old 04-02-2011, 06:48 PM
  #15
JK Freak
 
GutlessPhred's Avatar
 
Join Date: Mar 2010
Location: Lindon, Utah
Posts: 810
Thanks: 0
Thanked 0 Times in 0 Posts
Default

If you want, you can borrow my cord that came with mine so you know for sure that it is a superchips cord.
GutlessPhred is offline  
Reply With Quote
Old 04-02-2011, 08:02 PM
  #16
JK Enthusiast
Thread Starter
 
utahcrawler's Avatar
 
Join Date: Sep 2010
Location: Highland, Utah
Posts: 148
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks, I just might do that, I have been a big fan of this programmer, and frankly I miss it in my daily driving. I'll be in touch if I still can't get this to work.
utahcrawler is offline  
Reply With Quote
Old 04-03-2011, 09:08 AM
  #17
JK Freak
 
GutlessPhred's Avatar
 
Join Date: Mar 2010
Location: Lindon, Utah
Posts: 810
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by utahcrawler View Post
Thanks, I just might do that, I have been a big fan of this programmer, and frankly I miss it in my daily driving. I'll be in touch if I still can't get this to work.
Let me know if you want to use it. I can either bring it up or you can come get it. And if it works, you can update mine too.
GutlessPhred is offline  
Reply With Quote
Old 07-11-2011, 06:36 PM
  #18
JK Newbie
 
Join Date: Oct 2008
Location: Miami, FL
Posts: 86
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the very same issue. I had to go on their website re-register and download the latest software. Afterwards no more issues.

Their earlier software is garbage. Looks like the new software is much easier to work with. Before I could not get through to the internet and had other issues with the programer. I am using Vista.
kuma1720 is offline  
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Dynamo
Anything & Everything
9
07-26-2010 12:43 PM
joneszj
Modified JK Tech
0
10-12-2009 11:45 AM
nukeman
Modified JK Tech
0
04-13-2008 08:33 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 08:29 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: