Notices
Stock JK Tech Bulletin board forum regarding issues with OE (original equipment) components of the Jeep JK Wrangler (Rubicon, Sahara, Unlimited and X) such as factory suspension parts, engine, transmission, body parts, interior fixtures and the on-board computer.
Sponsored by DV8 Offroad
Click Here

I smell antifreeze!!

 
Old 05-08-2015, 08:47 AM
  #1  
JK Newbie
Thread Starter
 
shamisc's Avatar
 
Join Date: Aug 2012
Location: United States
Posts: 65
Likes: 0
Recieved 0 Likes on 0 Posts
Default I smell antifreeze!!

I've been smelling antifreeze for a couple of weeks now on my 2014 JKUS. No signs of leaks! Has anyone else experienced this?
shamisc is offline  
Old 05-08-2015, 09:28 AM
  #2  
JK Enthusiast
 
Join Date: Jun 2013
Location: coquitlam bc
Posts: 267
Likes: 0
Recieved 0 Likes on 0 Posts
Default

my 2013 does this.

still have not found the leak. dealer doesnt care lol.
jksteve2013 is offline  
Old 05-08-2015, 11:13 AM
  #3  
JK Freak
 
Earth Siege's Avatar
 
Join Date: Jun 2009
Location: Marshall, Texas
Posts: 929
Likes: 0
Recieved 1 Like on 1 Post
Default

Get under jeep and look at front of motor under the water pump. Chances are the leak is there or in that general area.
Earth Siege is offline  
Old 05-08-2015, 11:22 AM
  #4  
JK Enthusiast
 
Dodge4me's Avatar
 
Join Date: Mar 2014
Location: Bothell, WA
Posts: 356
Likes: 0
Recieved 0 Likes on 0 Posts
Default

Started noticing it a couple months ago too from the outside at the front. I have not been able to find any evidence if a leak nor has my coolant level gone down. 2014 with 16000 miles on it.
Dodge4me is offline  
Old 05-08-2015, 03:58 PM
  #5  
JK Junkie
 
rob_engineer's Avatar
 
Join Date: Feb 2012
Location: brick, nj
Posts: 2,827
Likes: 0
Recieved 21 Likes on 19 Posts
Default

One time I had a 1986 mustang. It developed a tiny pinhole in the heater core. The hole was so small that what came out was sort of atomized. It didn't leave a puddle. I would get a super fine fog condensing on the inside of my windshield. I drove a few weeks with a roll of paper towels in the passenger seat until I could afford to fix it. The carpet never got wet. Just the superfine mist.
rob_engineer is offline  
Old 05-08-2015, 04:42 PM
  #6  
JK Enthusiast
 
Join Date: Jan 2010
Location: Houston, TX
Posts: 236
Likes: 0
Recieved 0 Likes on 0 Posts
Default

Feel around the carpet on the passenger side up under dash. The heater core is in that general area and if it is leaking it will make your carpet wet and you will smell it.

Unfortunately you have to pull the entirdash to change the heater core.

BUT for a temp fix just route the coolant back into the motor. I did this until winter, as you will not have any heat.
Huntphreak is offline  
Old 05-08-2015, 05:17 PM
  #7  
JK Freak
 
sea bass's Avatar
 
Join Date: May 2009
Location: Enumclaw,WA
Posts: 998
Likes: 0
Recieved 0 Likes on 0 Posts
Default

My ’14 too! Just noticed this a few days ago...didn't check water pump yet
sea bass is offline  
Old 05-08-2015, 05:54 PM
  #8  
JK Newbie
 
MD GP's Avatar
 
Join Date: Dec 2011
Location: Northern California
Posts: 44
Likes: 0
Recieved 0 Likes on 0 Posts
Default

Originally Posted by shamisc View Post
I've been smelling antifreeze for a couple of weeks now on my 2014 JKUS. No signs of leaks! Has anyone else experienced this?
Hello,
I had a similar issue on my 2012 for almost a whole year. I never saw any dripping, but I slowly lost fluid. Finally, I parked it one day after a long climb and then came back while it was still hot. I could see it dripping. It was coming from what was, I believe, the plastic housing of the temperature sensor. It's located on the front of the engine to the right of midline (looking from front to back). It was easily replaced under warranty. I just looked for the paperwork but couldn't find it nor the part number. Might not be *your* problem, but probably worth taking a look at.
MD GP is offline  
Old 05-08-2015, 09:06 PM
  #9  
JK Enthusiast
 
Kellen's Avatar
 
Join Date: Oct 2012
Location: Kitsap Co. Washington
Posts: 262
Likes: 0
Recieved 0 Likes on 0 Posts
Default

I had a similar issue with my 08. I couldn't find and evidence of a leak anywhere but I would smell it and on cold mornings I would see occasional puffs of steam(?) when at a light or stop sign. Never could find it.
Kellen is offline  
Old 05-08-2015, 09:35 PM
  #10  
JK Freak
 
sea bass's Avatar
 
Join Date: May 2009
Location: Enumclaw,WA
Posts: 998
Likes: 0
Recieved 0 Likes on 0 Posts
Default

Originally Posted by MD GP View Post
Hello, I had a similar issue on my 2012 for almost a whole year. I never saw any dripping, but I slowly lost fluid. Finally, I parked it one day after a long climb and then came back while it was still hot. I could see it dripping. It was coming from what was, I believe, the plastic housing of the temperature sensor. It's located on the front of the engine to the right of midline (looking from front to back). It was easily replaced under warranty. I just looked for the paperwork but couldn't find it nor the part number. Might not be *your* problem, but probably worth taking a look at.
T-stat???
sea bass is offline  

Quick Reply: I smell antifreeze!!


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: